您的位置:首页 > 其它

hdu5045(压缩状态DP)

2016-06-08 20:53 302 查看
Problem Description

In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability

Input

The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.

Sample Input

1

2 3

0.6 0.3 0.4

0.3 0.7 0.9

Sample Output

Case #1: 2.20000

#include<stdio.h>
double a[11][1005];
double dp[1005][1<<10];
double max(double a,double b)
{
return (a>b?a:b);
}
int main()
{
int n,m;
int tt;
scanf("%d",&tt);
for(int t=1;t<=tt;t++)
{
scanf("%d%d",&n,&m);
int i,j,k;
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
scanf("%lf",&a[i][j]);
printf("Case #%d: ",t);
for(i=0;i<=m;i++)
for(j=0;j<(1<<n);j++)
dp[i][j]=-1;
dp[0][0]=0;
for(i=1;i<=m;i++)
for(j=0;j<(1<<n);j++)
if(dp[i-1][j]>=0)
{
for(k=0;k<n;k++)
{
int ans=1<<k;
if(ans&j) continue;
ans=ans|j;
if(ans==((1<<n)-1))
ans=0;
dp[i][ans]=max(dp[i][ans],dp[i-1][j]+a[k+1][i]);
}
}
double maxn=0;
for(i=0;i<(1<<n);i++)
maxn=max(maxn,dp[m][i]);
printf("%0.5lf\n",maxn);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: