您的位置:首页 > 其它

POJ-3295 Tautology

2016-06-08 17:38 281 查看
Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).

K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example,
ApNp is a tautology because it is true regardless of the value of p. On the other hand,
ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0

Sample Output
tautology
not

Source
Waterloo Local Contest, 2006.9.30

分析:暴力穷举模拟,因为编译器的短路原则WA了好几发。

#include <cstdio>
#include <iostream>
using namespace std;
int pos,p,q,r,s,t;
char S[10000];
bool deal()
{
pos+=1;
switch(S[pos])
{
case 'K' : { bool a = deal();bool b = deal();return a & b; }
case 'A' : { bool a = deal();bool b = deal();return a | b; }
case 'N' : return !deal();
case 'C' : { bool a = !deal();bool b = deal();return a | b; }
case 'E' : return deal() == deal();
case 'p' : return p;
case 'q' : return q;
case 'r' : return r;
case 's' : return s;
case 't' : return t;
}
}
int main()
{
while(scanf("%s",S) && S[0] != '0')
{
bool flag = false;
for(int i = 0;i < 32;i++)
{
pos = -1;
p = i & 1;
q = (i>>1) & 1;
r = (i>>2) & 1;
s = (i>>3) & 1;
t = (i>>4) & 1;
if(!deal())
{
flag = true;
cout<<"not"<<endl;
break;
}
}
if(!flag) cout<<"tautology"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: