您的位置:首页 > 产品设计 > UI/UE

11572 - Unique Snowflakes

2016-06-07 18:24 267 查看

Unique Snowflakes

Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold.

The marketing motto for the company is”bags of uniqueness.” To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed. The package can be completed and sealed before all of the snowflakes have flowed out of the machine.

Input

The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine. The following n lines each contain an integer (in the range 0 to 109 , inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical.

The input will contain no more than one million total snowflakes.

Output

For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.

Sample Input

1

5

1

2

3

2

1

Sample Output

3

输入一个长度为n(n≤106)的序列A,找到一个尽量长的连续子序列AL~AR,使得该序列中没有相同的元素。

#include <iostream>
#include <set>

using namespace std;

typedef long long LL;
const int maxNum = 1000000 + 5;
LL snowFlakes[maxNum];

int main() {
int T;
cin >> T;
while(T--) {
int n;
cin >> n;
for(int i = 0; i < n; i++) {
cin >> snowFlakes[i];
}

set<LL> ans;
LL lef = 0;
LL righ = 0;
LL num = 0;
while(righ < n) {
// 雪花不重复重复,则加入容器
while(righ < n && !ans.count(snowFlakes[righ])) {
ans.insert(snowFlakes[righ++]);
}
// 获取最大值
if((righ - lef) > num) {
num = righ - lef;
}
// 擦除到容器中没有相同元素
ans.erase(snowFlakes[lef++]);
}
cout << num << endl;
}
return 0;
}


#include <iostream>
#include <map>
#include <algorithm>
using namespace std;

const int maxNum = 1000000 + 5;
typedef long long LL;
LL snowFlakes[maxNum];
LL last[maxNum];
map<LL, LL> cur;

int main() {
int T;
cin >> T;
while(T--) {
int n;
cin >> n;
cur.clear();
for(int i = 0; i < n; i++) {
cin >> snowFlakes[i];
// 不存在容器中
if(!cur.count(snowFlakes[i])) {
last[i] = -1;
} else {
// 上一个相同的值的位置
last[i] = cur[snowFlakes[i]];
}
// 更新cur中的值
cur[snowFlakes[i]] = i;
}

LL lef = 0, righ = 0, ans = 0;
while(righ < n) {
while(righ < n && last[righ] < lef) {
righ++;
}
ans = max(ans, righ - lef);
lef++;
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVa11572 uva ACM