您的位置:首页 > 其它

PAT 1110

2016-06-07 12:54 218 查看


1110. Complete Binary Tree (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives
the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.
Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:
YES 8

Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题解:题目给你一颗树(不用考虑是不是森林),直接判断是不是完全二叉树;

我的方法是直接层序遍历,只要总的数量没到达n,如果在这之前出现“-”,则不是,否则返回最后一个节点;

提交的时候测试点二一直超时,后来发现是 num的大小必须没次都判断是否小于n,否则会无线循环;

ac代码:

#include <stdio.h>
#include <iostream>
#include <queue>
#include <stdlib.h>
#include <string.h>
#include <string>
using namespace std;
int root;
struct treenode
{
string left;
string right;
}t[22];
int n;
int k[22]={0};

int dfs(int a)
{
queue<int> q;
q.push(a);
int num=1;
int last=a;
while(!q.empty())
{
int temp=q.front();
if(t[temp].left=="-"&&num<n)
return -1;
else if(num<n){ int k=atoi(t[temp].left.c_str());q.push(k);num++;last=k;}
if(t[temp].right=="-"&&num<n)
return -1;
else if(num<n){ int k=atoi(t[temp].right.c_str());q.push(k);num++;last=k;}
q.pop();
if(num==n) return last;
}

}
int main ()
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
cin>>t[i].left;
cin>>t[i].right;
int ll=atoi(t[i].left.c_str());
int rr=atoi(t[i].right.c_str());
if(t[i].left!="-") k[ll]=1;
if(t[i].right!="-") k[rr]=1;
}
for(int i=0;i<n;i++)
{
if(k[i]==0)root=i;}
int r1=dfs(root);
if(r1==-1) printf("NO %d\n",root);
else printf("YES %d\n",r1);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  浙大PAT