您的位置:首页 > 其它

FZU 2148 Moon Game(判断凸边形(凹边形))

2016-06-01 17:35 369 查看

Moon Game

Description

Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of two-dimensional plane. Then Fat brother starts to draw N starts in the sky which we can just consider each as a point. After
he draws these stars, he starts to sing the famous song “The Moon Represents My Heart” to Maze.

You ask me how deeply I love you,

How much I love you?

My heart is true,

My love is true,

The moon represents my heart.



But as Fat brother is a little bit stay-adorable(呆萌), he just consider that the moon is a special kind of convex quadrilateral and starts to count the number of different convex quadrilateral in the sky. As this number is quiet large, he asks for your help.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains an integer N describe the number of the points.

Then N lines follow, Each line contains two integers describe the coordinate of the point, you can assume that no two points lie in a same coordinate and no three points lie in a same line. The coordinate of the point is in the range[-10086,10086].

1 <= T <=100, 1 <= N <= 30

Output

For each case, output the case number first, and then output the number of different convex quadrilateral in the sky. Two convex quadrilaterals are considered different if they lie in the different position in the sky.

Sample Input

240 0100 00 100100 10040 0100 00 10010 10

Sample Output

Case 1: 1Case 2: 0

解题思路:

给你n个点,判断能形成多少个凸多边形。

由于给的数据很小,因此可以直接暴力所有的点,但是凸多边形不是很好判断,可以转换为判断是否为凹多边形。如果存在一点d使

得:Sabc=Sabd+Sacd+Sbcd,则为凹边形。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

const double eps = 1e-9;
struct Point{
double x,y;
Point(double x=0,double y=0):x(x),y(y){} // 构造函数,方便代码编写
}po[35];
typedef Point Vector; //从程序实现上,Vector只是Point的别名

//点-点=向量
Vector operator - (Vector A,Vector B){
return Vector(A.x-B.x,A.y-B.y);
}

double Cross(Vector A,Vector B){
return A.x*B.y - A.y*B.x;
}

double area(Point a, Point b, Point c){
return Cross(b-a,c-a)/2;
}

bool check(Point a,Point b,Point c,Point d){
double sum1 = fabs(area(a, b, d)) + fabs(area(a, c, d)) + fabs(area(b, c, d));
double sum2 = fabs(area(a, b, c));
if(fabs(sum1 - sum2) < eps) return true;
return false;
}

bool solve(Point a,Point b,Point c,Point d){
if(check(a,b,c,d)) return false;
if(check(a,b,d,c)) return false;
if(check(a,c,d,b)) return false;
if(check(b,c,d,a)) return false;
return true;
}

int main(){
int T,t = 1;
scanf("%d",&T);
while(T--){
int n,ans = 0;
scanf("%d",&n);
for(int i = 0; i < n; ++i)
scanf("%lf%lf",&po[i].x,&po[i].y);
for(int i = 0; i < n; ++i)
for(int j = i+1; j < n; ++j)
for(int k = j+1; k < n; ++k)
for(int l = k+1; l < n; ++l)
if(solve(po[i],po[j],po[k],po[l]))
ans++;
printf("Case %d: %d\n",t++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: