您的位置:首页 > 其它

1013. Battle Over Cities (25) 连通图

2016-06-01 10:48 323 查看


1013. Battle Over Cities (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities
connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is
occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow,
each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3

Sample Output
1
0
0


提交代



题意:

(1)题目给出一张图,以及几条边。要求当去掉其中的一个顶点后为了使剩下的顶点可以连通需要增加多少条边。

(2)其实只要考虑去掉这个顶点后,剩余的顶点可以组成几个独立的区域,假设该区域数为t,则需要增加的边即为t-1

#include<iostream>
#include<string.h>
#include<cstdio>
#include<iomanip>
using namespace std;
int n,m,k;
int edge[1001][1001];
int visited[1001];
int x,y;
void dfs(int t)
{
visited[t]=1;
for(int i=1;i<=n;i++)
{
if(visited[i]==0&&edge[i][t]==1)
dfs(i);
}
}
int main()
{
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<m;i++)
{
scanf("%d%d",&x,&y);
edge[x][y]=1;
edge[y][x]=1;
}
int c;
for(int i=0;i<k;i++)
{
int cnt=0;
scanf("%d",&c);
memset(visited,0,sizeof(visited));
visited[c]=1;
for(int i=1;i<=n;i++)
{
if(visited[i]==0)
{
cnt++;
dfs(i);
}
}
printf("%d\n",cnt-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT