您的位置:首页 > 其它

POJ-2387 Til the Cows Come Home ( 最短路 )

2016-05-31 19:06 429 查看
题目链接: http://poj.org/problem?id=2387

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it,
uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in
which Bessie stands all day is landmark N. Cows travel in the field
using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation
ability, so she always stays on a trail from its start to its end once
she starts it.

Given the trails between the landmarks, determine the minimum
distance Bessie must walk to get back to the barn. It is guaranteed
that some such route exists.
Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated
integers. The first two integers are the landmarks between which the
trail travels. The third integer is the length of the trail, range
1..100.
Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

最短路模板题,求1到n的最短路


#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>

using namespace std;

int way[1005][1005];
bool flag[1005];
int main(){
ios::sync_with_stdio( false );

int n, m;

while( cin >> m >> n ){
int x, y, d;
memset( way, 0x3f3f3f3f, sizeof( way ) );
memset( flag, false, sizeof( flag ) );
for( int i = 0; i < m; i++ ){
cin >> x >> y >> d;
way[x][y] = way[y][x] = min( way[x][y], d );
}

for( int k = 0; k < n - 1; k++ ){
int minv = 0x3f3f3f3f, mini;

for( int i = 1; i < n; i++ ){
if( !flag[i] && minv > way
[i] ){
minv = way
[i];
mini = i;
}
}

flag[mini] = true;
for( int i = 1; i < n; i++ ){
if( !flag[i] ){
way
[i] = min( way
[i], way
[mini] + way[mini][i] );
}
}
}

cout << way
[1] << endl;
}

return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: