您的位置:首页 > 编程语言 > Go语言

SDUT 3222 Free Goodies(贪心+dp)

2016-05-31 10:13 381 查看


Free Goodies



Time Limit: 1000MS Memory limit: 65536K


题目描述

Petra and Jan have just received a box full of free goodies, and want to divide the goodies between them. However, it is not easy to do this fairly, since they both value different goodies differently.

To divide the goodies, they have decided upon the following procedure: they choose goodies one by one, in turn, until all the goodies are chosen. A coin is tossed to decide who gets to choose the first goodie.

Petra and Jan have different strategies in deciding what to choose. When faced with a choice, Petra always selects the goodie that is most valuable to her. In case of a tie, she is very considerate and picks
the one that is least valuable to Jan. (Since Petra and Jan are good friends, they know exactly how much value the other places on each goodie.)

Jan’s strategy, however, consists of maximizing his own final value. He is also very considerate, so if multiple choices lead to the same optimal result, he prefers Petra to have as much final value as possible. You
are given the result of the initial coin toss. After Jan and Petra have finished dividing all the goodies between themselves, what is the total value of the goodies each of them ends up with? 

You are given the result of the initial coin toss. After Jan and Petra have finished dividing all the goodies between themselves, what is the total value of the goodies each of them ends up with?
 


输入

On the first line a positive integer: the number of test cases, at most 100. After that per test case:

One line with an integer n (1 <=  n <= 1 000): the number of goodies.

One line with a string, either “Petra” or “Jan”: the person that chooses first.

n lines with two integers pi and ji (0 <= pi ,  ji <= 1 000) each: the values that Petra and Jan assign to the i-th goodie, respectively. 


输出

Per test case:
One line with two integers: the value Petra gets and the value Jan gets. Both values must be according to their own valuations.


示例输入

3
4
Petra
100 80
70 80
50 80
30 50
4
Petra
10 1
1 10
6 6
4 4
7
Jan
4 1
3 1
2 1
1 1
1 2
1 3
1 4



示例输出

170 130
14 16
9 10


#include <bits/stdc++.h>
using namespace std;
const int maxn = 1010;
struct node
{
int pi, ji;
bool operator < (node a)const
{
return pi == a.pi ? ji < a.ji : pi > a.pi;
}
}good[maxn];

int dp1[maxn][maxn], dp2[maxn][maxn];

int main()
{
std::ios::sync_with_stdio(false);
int T, n;
char str[12];
cin>>T;
while(T-- && cin>>n>>str)
{
memset(dp1, 0, sizeof(dp1));
memset(dp2, 0, sizeof(dp2));
long long sum = 0;
for(int i=1; i<=n; i++){
cin>>good[i].pi>>good[i].ji;
sum += good[i].pi;
}
sort(good+1, good+1+n);
if(str[0] == 'J')
{
for(int i=1; i<=n; i++){
for(int j=1; j<=(i+1)/2; j++){
if(dp1[i-1][j] > dp1[i-1][j-1] + good[i].ji){
dp1[i][j] = dp1[i-1][j];
dp2[i][j] = dp2[i-1][j];
} else if(dp1[i-1][j] == dp1[i-1][j-1] + good[i].ji){
dp1[i][j] = dp1[i-1][j];
dp2[i][j] = min(dp2[i-1][j], dp2[i-1][j-1]+good[i].pi);
} else{
dp1[i][j] = dp1[i-1][j-1] + good[i].ji;
dp2[i][j] = dp2[i-1][j-1] + good[i].pi;
}
}
}

printf("%d %d\n", sum-dp2
[(n+1)/2], dp1
[(n+1)/2]);
}
else
{
for(int i=1; i<n; i++){
for(int j=1; j<=(i+1)/2; j++){
if(dp1[i-1][j] > dp1[i-1][j-1] + good[i+1].ji){
dp1[i][j] = dp1[i-1][j];
dp2[i][j] = dp2[i-1][j];
} else if(dp1[i-1][j] == dp1[i-1][j-1] + good[i+1].ji){
dp1[i][j] = dp1[i-1][j];
dp2[i][j] = min(dp2[i-1][j], dp2[i-1][j-1]+good[i+1].pi);
} else{
dp1[i][j] = dp1[i-1][j-1] + good[i+1].ji;
dp2[i][j] = dp2[i-1][j-1] + good[i+1].pi;
}
}
}

printf("%d %d\n", sum-dp2[n-1][n/2], dp1[n-1][n/2]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: