您的位置:首页 > 其它

06-图2 Saving James Bond - Easy Version

2016-05-30 17:11 399 查看
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (N≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20

25 -15

-25 28

8 49

29 15

-35 -2

5 28

27 -29

-8 -28

-20 -35

-25 -20

-13 29

-30 15

-35 40

12 12

Sample Output 1:

Yes

Sample Input 2:

4 13

-12 12

12 12

-12 -12

12 -12

Sample Output 2:

No

思路:就是dfs,注意刚开始的时候不同(起点是一个半径为7.5的圆形区域,而不是一个点,还要考虑直接跳上岸)。其他就是正正规规的dfs

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=102;
typedef struct position position;
struct position{
int x,y;
}pos[maxn];
int N,D,visit[maxn];
bool flag=false;
void dfs(int index){
visit[index]=1;
if(pos[index].x+D>=50||pos[index].x-D<=-50||pos[index].y+D>=50||pos[index].y-D<=-50){
flag=true;
return;
}
for(int i=0;i<N;i++){
if(!visit[i]&&((pos[i].x-pos[index].x)*(pos[i].x-pos[index].x)+(pos[i].y-pos[index].y)*(pos[i].y-pos[index].y)<=D*D)){
dfs(i);
}
}
}
int main(){
//freopen("in.txt","r",stdin);
memset(visit,0,sizeof(visit));
scanf("%d%d",&N,&D);
for(int i=0;i<N;i++){
scanf("%d%d",&pos[i].x,&pos[i].y);
}
for(int i=0;i<N;i++){
if(D+7.5>=50){
flag=true;//直接跳上岸
}
else if(!visit[i]&&(pos[i].x*pos[i].x+pos[i].y*pos[i].y<=D*D+15*D+56)){
dfs(i);//起点能够到的位置
}
if(flag)
break;
}
if(flag){
puts("Yes");
}
else{
puts("No");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: