您的位置:首页 > 其它

1003

2016-05-29 14:09 225 查看
[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers
are between -1000 and 1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position
of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6这道题运用了动规思想,要注意的是这道题多了一个位置的记录,所以起点额选择会更新,因此要定义一个变量去记录起点的位置,而且还要注意输出的格式。
#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
int n;
int a[100010];
scanf("%d",&n);
int k=0,m,maxn,temp,position,begining,ending,i;
while(n--)
{
k++;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%d",&a[i]);
}
maxn=temp=a[0];
position=begining=ending=0;
for( i=1;i<m;i++)
{
if(temp+a[i]<a[i])
{
temp=a[i];
position=i;
}
else
{
temp+=a[i];
}
if(temp>maxn)
{
maxn=temp;
begining=position;
ending=i;
}

}
printf("Case %d:\n%d %d %d\n",k,maxn,begining+1,ending+1);
if(n)
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: