您的位置:首页 > 其它

POJ - 2253 Frogger

2016-05-28 21:11 267 查看
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming
and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates
of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three
decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意就是在能够到达Fiona的所有路径中,找到路径中最大的那条路是其他路径中最大的那条路的最小值。
题目中叫做minimax,我觉得十分形象啊。
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <iomanip>
using namespace std;

double x[1005], y[1005];
double path[1005][1005];

int main()
{
int T = 1;
int n;

while (T++)
{
scanf("%d", &n);
if (n == 0) break;

for (int i = 0; i < n; ++i)
scanf("%lf%lf", &x[i], &y[i]);
for (int i = 0; i < n-1; ++i)
{
for (int j = i+1; j < n; ++j)
{
double xx = x[i] - x[j];
double yy = y[i] - y[j];
path[i][j] = path[j][i] = sqrt(xx*xx + yy*yy);
}
}
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n-1; ++j)
{
for (int k = j+1; k < n; ++k)
{
if (path[i][j] < path[j][k] && path[i][k] < path[j][k])
{
if (path[i][j] < path[i][k])
path[j][k] = path[k][j] = path[i][k];
else
path[j][k] = path[k][j] = path[i][j];
}
}
}
}
cout << "Scenario #" << T-1 << endl;
cout << fixed << setprecision(3) << "Frog Distance = " << path[0][1] << endl;
cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM POJ