您的位置:首页 > Web前端

HDU 1015 Safecracker (DFS)

2016-05-28 11:20 357 查看

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12192    Accepted Submission(s): 6315


[align=left]Problem Description[/align]
=== Op tech briefing, 2002/11/02 06:42 CST ===

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution'
if there is no correct combination. Use the exact format shown below."

 
[align=left]Sample Input[/align]

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

 
[align=left]Sample Output[/align]

LKEBA
YOXUZ
GHOST
no solution

[align=left]Source[/align]
Mid-Central USA 2002

题解:输入target,和一连串字母,找出其中5个字母的字典序满足v - w^2 + x^3 - y^4 + z^5 = target。
           dfs撸一波。。。

AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<vector>
#include<list>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
int vis[13],k,m,n;
char s[13],c[13];
bool dfs (int cur,int count)
{
if(count==5)
{
if(cur==n)return true;
else return false;
}
for(int i=0;i<m;i++)
if(!vis[i])
{
vis[i]=1;
int num=s[i]-'A'+1; //字符对应得数字
c[k++]=s[i];
count++;
int yuanlai=cur;
//计算式子
if(count==1) cur+=num;
else if(count==2) cur-=num*num;
else if (count==3) cur+=num*num*num;
else if(count==4) cur-=num*num*num*num;
else if(count==5) cur+=num*num*num*num*num;
if(dfs(cur,count))
return true;
k--;
cur=yuanlai;
count--;
vis[i]=0;
}
return false;
}
int main()
{
while(scanf("%d ",&n)) //WA了半天。。。%d要后面留一个空格
{
k=0;
gets(s);
m=strlen(s);
memset(vis,0,sizeof(vis));
if(n==0&&strcmp(s,"END")==0)break;
//排序就是为了最后保留的为字典序最大的
for(int i=0;i<m;i++)
for(int j=i+1;j<m;j++)
if(s[i]<s[j])
{
char cs=s[i];
s[i]=s[j];
s[j]=cs;
}

if(dfs(0,0))
{
c[k]='\0';
puts(c);
}
else
printf("no solution\n");

}

return 0;
}


dfs再撸一波。。
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<vector>
#include<list>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
#define N 15

int ans[5],tmd
,len,target;
char ch
;
bool vis
;

int cmp(int a,int b)
{
return a>b;
}

bool dfs(int cur,int cou)
{
if(cou==5)
return cur==target;
for(int i=0;i<len;i++){
if(!vis[i]){
vis[i]=1;
int tmp=tmd[i];
ans[cou]=tmp;
int de=0;
switch(cou+1){
case 1:de+=tmp;break;
case 2:de-=tmp*tmp;break;
case 3:de+=tmp*tmp*tmp;break;
case 4:de-=tmp*tmp*tmp*tmp;break;
case 5:de+=tmp*tmp*tmp*tmp*tmp;break;
}
if(dfs(cur+de,cou+1)) return true;
vis[i]=0;
}
}
return false;
}
int main()
{
while(scanf("%d%s",&target,ch)!=EOF,target||strcmp(ch,"END"))
{
len=strlen(ch);
memset(vis,0,sizeof(vis));

for(int i=0;i<len;i++)
tmd[i]=ch[i]-'A'+1;

sort(tmd,tmd+len,cmp);

if(dfs(0,0)){
for(int i=0;i<5;i++)
printf("%c",ans[i]-1+'A');
printf("\n");
}
else
printf("no solution\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: