您的位置:首页 > 产品设计 > UI/UE

Anti-prime Sequences

2016-05-27 13:51 302 查看
Anti-prime Sequences

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 3355Accepted: 1531
Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence.

We can extend the definition by defining a degree danti-prime
sequence as one where all consecutive subsequences of length 2,3,...,d
sum to a composite number. The sequence above is a degree 2 anti-prime
sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11.
The lexicographically .rst degree 3 anti-prime sequence for these
numbers is 1,3,5,4,6,2,10,8,7,9.

Input

Input
will consist of multiple input sets. Each set will consist of three
integers, n, m, and d on a single line. The values of n, m and d will
satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0
0 will indicate end of input and should not be processed.
Output

For
each input set, output a single line consisting of a comma-separated
list of integers forming a degree danti-prime sequence (do not insert
any spaces and do not split the output over multiple lines). In the case
where more than one anti-prime sequence exists, print the
lexicographically first one (i.e., output the one with the lowest first
value; in case of a tie, the lowest second value, etc.). In the case
where no anti-prime sequence exists, output

No anti-prime sequence exists.

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54
题意:在【2,d】长度的连续序列的和都要为合数。
思路:DFS。


#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<stack>
#include<math.h>
using namespace std;
typedef long long LL;
bool prime[20000]= {0};
int tt[10000];
bool cm[1005];
int ts=0;
bool check(int n,int m);
int dfs(int n,int m,int d,int kk,int pp);
int main(void)
{
int i,j,k;
for(i=2; i<=1000; i++)
{
if(!prime[i])
{
for(j=i; (i*j)<=20000; j++)
{
prime[i*j]=true;
}
}
}
int n,m;
while(scanf("%d %d %d",&n,&m,&k),n!=0&&m!=0&&k!=0)
{
memset(cm,0,sizeof(cm));
ts=0;
int uu=dfs(0,m-n+1,k,n,m);
if(uu)
{
printf("%d",tt[0]);
for(i=1; i<(m-n+1); i++)
{
printf(",%d",tt[i]);
}
printf("\n");
}
else printf("No anti-prime sequence exists.\n");
}
}
bool check(int n,int m)
{
int i,j;

LL sum=tt[m];
for(i=m-1; i>=max(n,0); i--)
{
sum+=tt[i];
if(!prime[sum])
return false;
}
return true;
}
int dfs(int n,int m,int d,int kk,int pp)
{
int i;
if(ts)return 1;
if(n==m)
{

bool cc=check(n-d,m-1);
if(!cc)
{
return 0;
}
ts=1;
return 1;
}
else
{
bool cc=check(n-d,n-1);
if(cc)
{
for(i=kk; i<=pp; i++)
{
if(ts)return 1;
if(!cm[i])
{
tt
=i;
cm[i]=true;
int uu=dfs(n+1,m,d,kk,pp);
cm[i]=false;
if(uu)return 1;
}
}
}
else return 0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: