您的位置:首页 > 其它

hdoj-2055-An easy problem

2016-05-26 16:20 423 查看
[align=left]Problem Description[/align]
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).
 

[align=left]Input[/align]
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

[align=left]Output[/align]
for each case, you should the result of y+f(x) on a line.
 

[align=left]Sample Input[/align]

6
R 1
P 2
G 3
r 1
p 2
g 3

 

[align=left]Sample Output[/align]

19
18
10
-17
-14
-4

上AI实验课闲来无事随便找了一题写的

sabi题不解释

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;
map<char,int>a[60];

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
char c;
int n;
int sum=0;
getchar();
scanf("%c",&c);
scanf("%d",&n);
if(c>='A'&&c<='Z') sum=c-'A'+1;
else if(c>='a'&&c<='z') sum=(c-'a'+1)*(-1);
sum+=n;
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: