您的位置:首页 > 其它

POJ 1017 Packets

2016-05-26 08:28 218 查看
Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50659 Accepted: 17141
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.
Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1


装箱问题  

    问题描述 

    一个工厂制造的产品形状都是长方体,它们的高度都是h,长和宽都相等,一共有六个 

型号,他们的长宽分别为 1*1, 2*2, 3*3, 4*4, 5*5, 6*6.  这些产品通常使用一个  6*6*h       

的长方体包裹包装然后邮寄给客户。因为邮费很贵,所以工厂要想方设法的减小每个订单运送时的 

包裹数量。他们很需要有一个好的程序帮他们解决这个问题从而节省费用。现在这个程序由 

你来设计。  

    输入数据  

    输入文件包括几行,每一行代表一个订单。每个订单里的一行包括六个整数,中间用空 

格隔开,分别为 1*1 至6*6 这六种产品的数量。输入文件将以 6 个0 组成的一行结尾。  

    输出要求  

    除了输入的最后一行6 个0 以外,输入文件里每一行对应着输出文件的一行,每一行输 

出一个整数代表对应的订单所需的最小包裹数。  

   

    解题思路 

    这个问题描述得比较清楚,我们在这里只解释一下输入输出样例:共有两组有效输入, 

第一组表示有4 个3*3 的产品和一个6*6 的产品,此时4 个 3*3 的产品占用一个箱子,另外 

一个 6*6 的产品占用 1 个箱子,所以箱子数是 2;第二组表示有7 个 1*1 的产品,5 个 2*2 

的产品和1 个 3*3 的产品,我们可以把他们统统放在一个箱子中,所以输出是1。 

    分析六个型号的产品占用箱子的具体情况如下:6*6的产品每个会占用一个完整的箱 

子,并且没有空余空间;5*5  的产品每个占用一个新的箱子,并且留下 11 个可以盛放 1*1 

的产品的空余空间;4*4 的产品每个占用一个新的箱子,并且留下5 个可以盛放2*2 的产品 

的空余空间;3*3 的产品情况比较复杂,首先3*3 的产品不能放在原来盛有5*5 或者4*4 的

箱子中,那么必须为3*3 的产品另开新的箱子,新开的箱子数目等于3*3 的产品的数目除以 

4  向上取整;同时我们需要讨论为3*3 的产品新开箱子时,剩余的空间可以盛放多少2*2 和 

1*1 的产品(这里如果有空间可以盛放2*2 的产品,我们就将它计入2*2 的空余空间,等到 

2*2  的产品全部装完,如果还有2*2  的空间剩余,再将它们转换成 1*1 的剩余空间)。我们 

可以分情况讨论为3*3 的产品打开的新箱子中剩余的空位,共为四种情况:第一种,3*3 的 

产品的数目正好是4 的倍数,所以没有空余空间;第二种,3*3 的产品数目是4 的倍数加1, 

这时还剩 5 个2*2 的空位和7 个 1*1 的空位;第三种,3*3 的产品数目是4 的倍数加2,这 

时还剩3 个2*2 的空位和6 个 1*1 的空位;第四种,3*3 的产品数目是4 的倍数加3,这时 

还剩 1 个 2*2  的空位和5 个 1*1 的空位;处理完3*3  的产品,就可以比较一下剩余的2*2 

的空位和2*2 产品的数目,如果产品数目多,就将2*2 的空位全部填满,再为2*2 的产品打 

开新箱子,同时计算新箱子中 1*1 的空位,如果剩余空位多,就将2*2 的产品全部填入2*2 

的空位,再将剩余的 2*2  的空位转换成 1*1 的空位;最后处理 1*1 的产品,比较一下 1*1 

的空位与1*1 的产品数目,如果空位多,将1*1 的产品全部填入空位,否则,先将1*1 的空 

位填满,然后再为 1*1 的产品打开新的箱子。
#include <cstdio>
using namespace std;

int a, b, c, d, e, f;
//数组u 表示3*3 的产品数目分别是 4的倍数,4 的倍数+1, 4 的倍数+2, 4 的倍数+3
//时,为3*3的产品打开的新箱子中剩余的 2*2的空位的个数
int u[4] = {0, 5, 3, 1};
//n用来存储需要的箱子数目,y用来存储 2*2 的空位数目
//x 用来存储 1*1 的空位数目
int n;
int x, y;

int main()
{
while (scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f), a || b || c || d || e || f){
//这里有一个小技巧 - (c+3)/4  正好等于 c 除以4向上取整的结果,下同
n = f + e + d + (c + 3) / 4;
//每一个4*4的箱子装过后还可以再装5个2*2的箱子
//还有3*3的箱子如果没填满6*6的箱子的话,也可以用来装2*2的箱子
//5*5的箱子则只能装1*1的情况了
y = 5 * d + u[c % 4];
//如果要装的2*2的箱子的数目比提供的空间要多,
//那么多的部分要新开一些箱子
if (b > y)
n += (b - y + 8) / 9;
x = 36 * n - 36 * f - 25 * e - 16 * d - 9 * c - 4 * b;
if (a > x)
n += (a - x + 35) / 36;
printf("%d\n", n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: