您的位置:首页 > 其它

HDU 2035 人见人爱A^B(快速幂)

2016-05-25 14:14 405 查看
http://acm.hdu.edu.cn/showproblem.php?pid=2035

Problem Description

求A^B的最后三位数表示的整数。

说明:A^B的含义是“A的B次方”

Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input

2 3

12 6

6789 10000

0 0

Sample Output

8

984

1

本题是一道快速幂的题目。暴力没试,目测可以过。快速幂的时间是0ms,下面是AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

int quick_mod(int a,int b,int mod)
{
int ans=1;
while(b)
{
if(b&1)
{
ans=(ans*a)%mod;
b--;
}
b=b/2;
a=a*a%mod;
}
return ans;
}

int main()
{
int a,b;
while(~scanf("%d%d",&a,&b))
{
if(a==0&&b==0)
{
break;
}
int re=quick_mod(a,b,1000);
printf("%d\n",re);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU