您的位置:首页 > 产品设计 > UI/UE

hdu 1711 Number Sequence -- (KMP 求数列第一匹配的位置)

2016-05-24 21:23 471 查看


Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19786    Accepted Submission(s): 8498


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

Sample Output

6
-1

 
#include <stdio.h>
#include <string.h>
#define N 1000005
int t
,w
;
int next
;
int n,m;
void get_next(int *a,int len){
next[0]=-1;
int i=0,j=-1;
while(i<len){
if(j==-1||a[i]==a[j]){
if(a[++i]==a[++j]) next[i]=next[j];
else next[i]=j;
}
else j=next[j];
}
}
int KMP(int *a,int *b){  //a是主串
int i=0,j=0;
int sum=0;
get_next(b,m);
while(i<n&&j<m){
if(j==-1||a[i]==b[j]) i++,j++;
else  j=next[j];
if(j==m){
return i-j+1;
}
}
return -1;
}
int main(){
int T,i;
scanf("%d",&T);
while(T--){
scanf("%d %d",&n,&m);
for(i=0;i<n;i++) scanf("%d",&t[i]);
for(i=0;i<m;i++) scanf("%d",&w[i]);
printf("%d\n",KMP(t,w));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: