您的位置:首页 > 其它

生生世世是生生世世是水题

2016-05-22 11:28 162 查看
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture,
can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



 
[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

 
[align=left]Output[/align]
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

 
[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222


 
[align=left]Sample Output[/align]

33.33
40.69
Hint
For float may be not accurate enough, please use double instead of float.

 
[align=left]Author[/align]
Ignatius.L
#include <iostream>
#include <stdio.h>
#include <iomanip>
#include <stdio.h>
using namespace std;
int main()
{
int t;
cin>>t;
double x1,y1;
double x2,y2;
double x3,y3;
double a,b,c;
double a1,b1;
double aa,bb;
double aa1,bb1;
while(t--)
{
cin>>x1>>y1;
cin>>x2>>y2;
cin>>x3>>y3;
a=(y1-y2)/((x1*x1-x2*x2)-2*x1*(x1-x2));
b=-1*2*a*x1;
c=y2-(a*x2*x2+b*x2);
//cout<<a<<" "<<b<< " "<<c<<endl;
aa=(1/3.0)*a*x2*x2*x2+0.5*b*x2*x2+c*x2;
bb=(1/3.0)*a*x3*x3*x3+0.5*b*x3*x3+c*x3;
a1=(y3-y2)/(x3-x2);
b1=-1*1.0*x3*(a1)+y3;
aa1=(0.5)*a1*x2*x2+b1*x2;
bb1=(0.5)*a1*x3*x3+b1*x3;
//cout<<bb1-aa1<<endl;
//cout<<bb-aa<<endl;
cout<<fixed<<setprecision(2)<<bb-aa-bb1+aa1<<endl;
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: