您的位置:首页 > 其它

ACM: 图论题poj 1860 (没心情复习…

2016-05-19 23:16 344 查看
                                                               
Currency Exchange

Description

Several currency exchange points are working in our city. Let us
suppose that each point specializes in two particular currencies
and performs exchange operations only with these currencies. There
can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is
the quantity of B you get for 1A. Also each exchange point has some
commission, the sum you have to pay for your exchange operation.
Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian
Rubles at the exchange point, where the exchange rate is 29.75, and
the commission is 0.39 you will get (100 - 0.39) * 29.75 =
2963.3975RUR.

You surely know that there are N different currencies you can deal
with in our city. Let us assign unique integer number from 1 to N
to each currency. Then each exchange point can be described with 6
numbers: integer A and B - numbers of currencies it exchanges, and
real RAB, CAB, RBA and CBA - exchange rates and commissions when
exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow,
after some exchange operations, increase his capital. Of course, he
wants to have his money in currency S in the end. Help him to
answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number
of currencies, M - the number of exchange points, S - the number of
currency Nick has and V - the quantity of currency units he has.
The following M lines contain 6 numbers each - the description of
the corresponding exchange point - in specified above order.
Numbers are separated by one or more spaces.
1<=S<=N<=100,
1<=M<=100, V is real number,
0<=V<=103.

For each point exchange rates and commissions are real, given with
at most two digits after the decimal point,
10-2<=rate<=102,
0<=commission<=102.

Let us call some sequence of the exchange operations simple if no
exchange point is used more than once in this sequence. You may
assume that ratio of the numeric values of the sums at the end and
at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output
NO to the output file.

Sample Input

3 2 1 20.0

1 2 1.00 1.00 1.00 1.00

2 3 1.10 1.00 1.10 1.00

Sample Output

YES

 

题意: Nick现在有第S种货币,他所在的城市有N种货币流通,有M个货币兑换的点.

        
现在他想知道是否可以获得利润.最后兑换回第S种货币.(正环的标志)

个人思路:

              
1.从题目的意思可以发现是一题图论题.求解是否有正环的题.

              
2.bellman_ford求解.但是算法要改一改.这次不是求最短路径.而是判断正环是否存在.

              
3.简单的说就是走了一圈回到原点,是否获得利润.(呵呵最直观的说法.)

              
4.重点: bellman_ford算法的外层循环就不再是迭代n-1个点了,而是判断dist[start]
<= 本金.

             
(一开始不知道bellman_ford算法时一头雾水的题,今天变成水题了.呵呵!!)

 

代码:

#include <cstdio>

#include <iostream>

#include <cstring>

using namespace std;

#define MAX 1005

int n , m , start;

double value;

int u[MAX] , v[MAX];

double r[MAX] , c[MAX] , dist[MAX];

void readGraph()  //读入图

{

    for(int i =
0; i < 2*m; ++i)

    {

  
   
 int uu , vv;

  
   
 double rab,rba,cab,cba;

  
   
 scanf("%d %d %lf %lf %lf
%lf",&uu,&vv,&rab,&cab,&rba,&cba);

  
   
 u[i] = uu;

  
   
 v[i] = vv;

  
   
 r[i] = rab;

  
   
 c[i++] = cab;

  
   
 u[i] = vv;

  
   
 v[i] = uu;

  
   
 r[i] = rba;

  
   
 c[i] = cba;

    }

}

bool bellman_ford()

{

  
 memset(dist,0,sizeof(dist));

    dist[start]
= value;

    bool flag =
false;

  
 while(dist[start] <=
value)   //改成正环判断的外层循环

    {

  
   
 flag = false;  //设置出口

  
   
 for(int i = 0; i < 2*m; ++i)

  
   
 {

  
   
   
 if(dist[ v[i] ] < (dist[u[i]] -
c[i]) * r[i] ) //判断需要松弛.

  
   
   
 {

  
   
   
   
 flag = true;

  
   
   
   
 dist[ v[i] ] = (dist[u[i]] - c[i]) * r[i];

  
   
   
 }

  
   
 }

  
   
 if(flag ==
false)  
//当全部边不断迭代时,已经找到结果的出口

  
   
 {

  
   
   
 if(dist[start] <= value)
//判断正环

  
   
   
   
 return false;

  
   
   
 else

  
   
   
   
 return true;

  
   
 }

    }

    return
true;

}

int main()

{

  
 while(scanf("%d %d %d
%lf",&n,&m,&start,&value)
!= EOF)

    {

  
   
 readGraph();

  
  <
4000
/p>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: