您的位置:首页 > 其它

C

2016-05-19 20:14 183 查看
Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.<br><br><center><img src=/data/images/1087-1.jpg></center><br><br>The game
can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course
of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go
from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping
solution. Note that your score comes from the sum of value on the chessmen in you jumping path.<br>Your task is to output the maximum value according to the given chessmen list.<br>

 

Input

Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input
and this test case is not to be processed.<br>

 

Output

For each case, print the maximum according to rules, and one line one case.<br>

 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

Sample Output

4
10
3

 题目大意:给你一串数你要从第一个开始往后跳只能向后分数是跳过的所有数的和并且后面的数必须大于前面的数求最大分数

思路:假设跳到第i个元素那从他可能是从1-i-1中的任何一个比第i个元素小的跳过来的,所以求当前状态必须要注意两点一去上个计分最大的跳到的当前状态,且上个状态的最后一个元素必须比当前的状态的元素小。

代码:

#include<iostream>

using namespace std;

int main()

{

    int n;

    int imax;

    int a[1001];

    int dp[1001];

    while (cin>>n&&n!=0)

    {

        imax=0;

        for(int i=0;i<n;i++)

        {

            cin>>a[i];

            dp[i]=a[i];

        }

        for(int i=1;i<n;i++)

    {

           for(int j=0;j<i;j++)

           {

               if(a[j]<a[i])

                dp[i]=max(dp[i],dp[j]+a[i]);

           }

           if(imax<dp[i])

            imax=dp[i];

        }

        cout<<imax<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: