您的位置:首页 > 其它

HDU2845-Beans

2016-05-19 18:26 302 查看


Beans

                                                                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
32768/32768 K (Java/Others)

                                                                                                      Total Submission(s): 4174    Accepted Submission(s): 1982


Problem Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following
rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.



Now, how much qualities can you eat and then get ?

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

 

Output

For each case, you just output the MAX qualities you can eat and then get.

 

Sample Input

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

 

Sample Output

242

 
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
int x[200009],y[200009],m,n,a;
while(~scanf("%d %d",&m,&n))
{
for(int i=2;i<=m+1;i++)
{
for(int j=2;j<=n+1;j++)
{
scanf("%d",&a);
x[j]=max(x[j-1],x[j-2]+a);
}
y[i]=max(y[i-1],y[i-2]+x[n+1]);
}
printf("%d\n",y[m+1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: