您的位置:首页 > 其它

POJ——1195Mobile phones(二维树状数组点修改矩阵查询)

2016-05-17 23:48 417 查看
Mobile phones

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 17764Accepted: 8213
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table.



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output
3
4


刚开始没处理好坐标关系和变量名修改后忘记下面也要改。杯具WA好几次。

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define INF 0x3f3f3f3f
#define MM(x) memset(x,0,sizeof(x))
using namespace std;
typedef long long LL;
const int N=1050;
int list

;
int cc

;
inline int lowbit(int k)
{
return k&-k;
}
inline void add(int x, int y, int d)
{
int i, j;
for(i = x; i < N; i += lowbit(i))
for(j = y; j < N; j += lowbit(j))
cc[i][j] += d;
}

inline int sum(int x, int y)
{
int res = 0;
int i, j;
for(i = x; i > 0; i -= lowbit(i))
for(j = y; j > 0; j -= lowbit(j))
res += cc[i][j];
return res;
}
int main (void)
{
int t,a,b,c,d,ans,i,j,n,shui,S,ops;
while(~scanf("%d",&ops))
{
if(ops==0)
{
scanf("%d",&S);
MM(cc);
}
else if(ops==1)
{
scanf("%d%d%d",&a,&b,&c);
add(a+1,b+1,c);
}
else if(ops==2)
{
scanf("%d%d%d%d",&a,&b,&c,&d);
ans=sum(c+1,d+1)+sum(a,b)-sum(a,d+1)-sum(c+1,b);
printf("%d\n",ans);
}
else if(ops==3)
break;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: