您的位置:首页 > 其它

POJ 2001-Shortest Prefixes【字典树】

2016-05-16 18:18 423 查看
Shortest Prefixes

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 16880Accepted: 7327
Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string
is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that
uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

Rocky Mountain 2004
解题思路:
输入完上面的所有字符后我们要 ctrl+z,输出每个字符的最长序列,只要这里面又一次出现就算。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
typedef struct node
{
int cnt;
node *next[26];
}Trie;
Trie root;
void ct(char *str)
{
int len,i,j;
len=strlen(str);
Trie *p=&root,*q;
for(i=0;i<len;i++)
{
int id=str[i]-'a';
if(p->next[id]==NULL)
{
q=new Trie;
q->cnt=1;
for(j=0;j<26;j++)
q->next[j]=NULL;
p->next[id]=q;
p=p->next[id];
}
else
{
p->next[id]->cnt++;
p=p->next[id];
}
}
}
void Find_Trie(char*str)
{
int len,i,j,id;
len=strlen(str);
Trie*p=&root;
for( i=0; i<len; i++){
id=str[i]-'a';
if( p->next[id]==NULL)
return ;
if(p->next[id]->cnt==1)
{
printf("%c",str[i]);
return ;
}
else if(p->next[id]->cnt>1)
{
printf("%c",str[i]);
p=p->next[id];
}
}
return ;
}
char xx[1050][25];
int main()
{
char map[1050];
int ii=0;
while(scanf("%s",map)!=EOF)
{
ct(map);
strcpy(xx[ii],map);
ii++;
}
for(int j=0;j<ii;j++)
{
printf("%s ",xx[j]);
Find_Trie(xx[j]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: