您的位置:首页 > 其它

hdu 1546(dijkstra)

2016-05-13 16:17 295 查看

Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3154 Accepted Submission(s): 1026


[align=left]Problem Description[/align]
Tom
is playing a game called Idiomatic Phrases Game. An idiom consists of
several Chinese characters and has a certain meaning. This game will
give Tom two idioms. He should build a list of idioms and the list
starts and ends with the two given idioms. For every two adjacent
idioms, the last Chinese character of the former idiom should be the
same as the first character of the latter one. For each time, Tom has a
dictionary that he must pick idioms from and each idiom in the
dictionary has a value indicates how long Tom will take to find the next
proper idiom in the final list. Now you are asked to write a program to
compute the shortest time Tom will take by giving you the idiom
dictionary.

[align=left]Input[/align]
The
input consists of several test cases. Each test case contains an idiom
dictionary. The dictionary is started by an integer N (0 < N <
1000) in one line. The following is N lines. Each line contains an
integer T (the time Tom will take to work out) and an idiom. One idiom
consists of several Chinese characters (at least 3) and one Chinese
character consists of four hex digit (i.e., 0 to 9 and A to F). Note
that the first and last idioms in the dictionary are the source and
target idioms in the game. The input ends up with a case that N = 0. Do
not process this case.

[align=left]Output[/align]
One
line for each case. Output an integer indicating the shortest time Tome
will take. If the list can not be built, please output -1.

[align=left]Sample Input[/align]

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

[align=left]Sample Output[/align]

17
-1
题意:给出n组"成语",每个成语都有其权值,对于任意两个成语,如果第一个成语的后4个字符能够与另外一个成语的前4个字符匹配,则这两个成语是可以接上去的,问从第一个成语开始,能否找到一条接的顺序,让第一个成语能够接到最后一个.如果能,输出接到最后一个所花费的最小代价,不能够则输出-1.
题解:将每个成语看成一个点,能够接上去则连上一条边。然后dijkstra算法进行求解.

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <queue>
using namespace std;
const int N = 1005;
const int INF = 99999999;
struct Node{
char s[5],e[5];
int w;
}node
;
int graph

;
int n;
void deal(char s[],int id){
for(int i=0;i<4;i++) node[id].s[i] = s[i];
int len = strlen(s);
int k =0;
for(int i=len-4;i<len;i++) {
node[id].e[k++] = s[i];
}
}
int low
;
bool vis
;
void dijkstra(int s){
memset(vis,false,sizeof(vis));
for(int i=0;i<n;i++){
low[i] = (i==s)?0:graph[s][i];
}
vis[s] = true;
for(int i=1;i<n;i++){
int Min = INF;
for(int j=0;j<n;j++){
if(Min>low[j]&&!vis[j]){
s=j;
Min = low[j];
}
}
vis[s] = true;
for(int j=0;j<n;j++){
if(low[j]>low[s]+graph[s][j]&&!vis[j]){
low[j]=low[s]+graph[s][j];
}
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF&&n){
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(i==j) graph[i][j] = 0;
else graph[i][j]=INF;
}
}
for(int i=0;i<n;i++){
char str
;
scanf("%d%s",&node[i].w,str);
deal(str,i);
}
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(strcmp(node[i].e,node[j].s)==0) graph[i][j] = node[i].w;
}
}
dijkstra(0);
if(low[n-1]>=INF) printf("-1\n");
else printf("%d\n",low[n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: