您的位置:首页 > 其它

F - Piggy-Bank——HOJ 一维DP 装载问题

2016-05-12 19:15 393 查看
F - Piggy-Bank
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4


Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.


一维DP,类似于0-1背包 动规:

#include<stdio.h>
#include<string.h>
int inf=999999;
int my_min(int x,int y)  {return x>y?y:x;}
typedef struct coin{
int p;
int	w;
}COIN;
COIN que[505];
int dp[10005];
int main()
{
int T,i,j,e,f,n,m,p,w;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
scanf("%d %d",&e,&f);
m=f-e;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d %d",&que[i].p,&que[i].w);
}

dp[0]=0;
for(i=1;i<=m;i++)
{
if(dp[i]==0)  dp[i]=inf;
for(j=1;j<=n;j++)
{
if(i>=que[j].w) //不要忘记等于号,否则,该点就不是局域最小
dp[i]=my_min(dp[i-que[j].w]+que[j].p,dp[i]);//动规方程
}
}
if(dp[m]!=inf)
printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
else
printf("This is impossible.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: