您的位置:首页 > 其它

bfs counting sheeps

2016-05-12 09:08 295 查看

Counting Sheep

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 4

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided
to try it out. The only problem was, there were no sheep around to be counted when I went to bed.



Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
A and C are in the same flock.

Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input

The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints

0 < T <= 100

0 < H,W <= 100

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###


Sample Output

6
3


Source

代码:

#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;
char map[101][101];
int vis[101][101];
int m,n,ans;
void bfs(int i,int j)
{
if(map[i][j]=='#'&&i>=0&&i<m&&j>=0&&j<n&&vis[i][j]==0)
{
vis[i][j]=1;
bfs(i+1,j);
bfs(i-1,j);
bfs(i,j+1);
bfs(i,j-1);
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
ans=0;
memset(vis,0,sizeof(vis));
cin>>m>>n;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
cin>>map[i][j];
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(map[i][j]=='#'&&vis[i][j]==0)
{
ans++;
bfs(i,j);
}
cout<<ans<<endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs