您的位置:首页 > 其它

hdu——1062Text Reverse(反转函数reverse)

2016-05-11 22:24 309 查看
Text Reverse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25706 Accepted Submission(s): 9959

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3

olleh !dlrow

m'I morf .udh

I ekil .mca

Sample Output

hello world!

I'm from hdu.

I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

Author

Ignatius.L

Recommend

注意最后一部份也要反转

#include<string>
#include<algorithm>
#include<iostream>
#include<sstream>
using namespace std;
int main()
{
long long m,n;
string a;
cin>>n;
getchar();
while(n--)
{
m=0;
getline(cin,a);
while(a.find(" ",m)!=string::npos)
{
reverse(a.begin()+m,a.begin()+a.find(" ",m));
m=a.find(" ",m)+1;
}
reverse(a.begin()+a.find_last_of(" ")+1,a.end());
cout<<a<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: