您的位置:首页 > 其它

hdu 1212 Big Number(大数取余)

2016-05-10 23:30 357 查看

Big Number(大数取余)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6998 Accepted Submission(s): 4819

Problem Description

As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output

For each test case, you have to ouput the result of A mod B.

Sample Input

2 3

12 7

152455856554521 3250

Sample Output

2

5

1521

链接在这

代码:

#include<stdio.h>
#include<string.h>
char a[1005];
int c[1005];
int b;
int main()
{
while(scanf("%s %d",a,&b)!=EOF)
{
for(int i=0; i<strlen(a); i++)
{
c[i]=a[i]-'0';
}
long long ans=0;
for(int i=0;i<strlen(a);i++)
{
ans=((long long)(ans*10+c[i])%b);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: