您的位置:首页 > 其它

poj 2431 Expedition (贪心加优先队列)

2016-05-10 13:44 387 查看
Expedition

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11538Accepted: 3336
Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P
Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10

Sample Output
2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
Source
USACO 2005 U S Open Gold

题意:

有n个加油站,离终点的距离不同,每次最多加一定量的油,

一辆汽车从起点出发,起始有一定量的油,每走一个单位的距离

会消耗一个单位的油,求最少的加油次数;

思路:

要想加油次数最少,应该满足两个条件

1.在没油的时候加油

2.每次加油都加,能加最多的油

做法:

我们应该在车有油的情况下,记录行驶过程中经过的加油站

,并放在优先队列中,没油的时候就加最多的油,如果在行驶过程中,

没有油可以加,则输出-1

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

struct node{
int dis;
int fue;
}a[10010];

priority_queue<int> q;

int cmp(node x,node y){
return x.dis > y.dis;
}

int main(){
int i,t,n,l,p,s,pos;
while(~scanf("%d",&n)){
for(i=0;i<n;i++)
scanf("%d%d",&a[i].dis,&a[i].fue);
sort(a,a+n,cmp);
scanf("%d%d",&l,&p);
s=0;
pos=0;
q.push(p);
while(l>0&&!q.empty()){
s++;
t=q.top();
q.pop();
l-=t;
while(pos<n&&l<=a[pos].dis)
q.push(a[pos++].fue);
}
if(l<=0)
printf("%d\n",s-1);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: