您的位置:首页 > 其它

POJ 3026 Borg Maze(BFS+最小生成树【有坑】)

2016-05-09 16:31 459 查看
Borg Maze

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 12012 Accepted: 3924

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space
'' stands for an open space, a hash mark
#” stands for an obstructing wall, the capital letter
A'' stand for an alien, and the capital letter
S” stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the “S”. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
#####
#A#A##
# # A#
#S  ##
#####
7 7
#####
#AAA###
#    A#
# S ###
#     #
#AAA###
#####


Sample Output

8

11

【坑点】:n,m之后有一堆空格,,,,坑死大大了,,,以后大家可以注意下。getchar()都用gets()代替

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<iostream>
#define INF 0x7fffffff
#define eps 1e-6
using namespace std;
int n,m,xl,yl;
int cot;
int xx[]= {-1,1,0,0};
int yy[]= {0,0,-1,1};
struct lx
{
int u,v,len;
} l[50*1001];
int fa[1001];

bool vis[151][151];
char g[151][151];
int site[151][151];
struct node
{
int x,y,lv;
} point[1001];
bool cmp(lx a,lx b)
{
return a.len<b.len;
}
int father(int x)
{
if(x!=fa[x])
return fa[x]=father(fa[x]);
}
void BFS(node S)
{
memset(vis,0,sizeof(vis));
queue<node>q;
q.push(S);
vis[S.x][S.y]=1;
int u=site[S.x][S.y];
int num=1;
while(!q.empty())
{
node now,tmp;
tmp=q.front();
q.pop();
int v=site[tmp.x][tmp.y];
if(v>=1&&u!=v)
{
l[cot].u=u;
l[cot].v=v;
l[cot++].len=tmp.lv;
num++;
}
if(num==n)break;
for(int k=0; k<4; k++)
{
int x=tmp.x+xx[k];
int y=tmp.y+yy[k];
if(y>=yl||y<0||x>=xl||x<0||g[x][y]=='#'||vis[x][y])
continue;
vis[x][y]=1;
now.lv=tmp.lv+1;
now.x=x,now.y=y;
q.push(now);
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&xl,&yl);
char str[51];
memset(site,0,sizeof(site));
n=1;
gets(str);
for(int i=0; i<yl; i++)
{
gets(str);
for(int j=0; j<xl; j++)
{
g[i][j]=str[j];
if(str[j]=='A'||str[j]=='S')
{
site[i][j]=n;
point
.x=i,point
.y=j;
point[n++].lv=0;

}
}
}
cot=0;
n--;
for(int i=1; i<=n; i++)
BFS(point[i]);
for(int i=1; i<=n; i++)
fa[i]=i;
sort(l,l+cot,cmp);
int ans=0;
for(int i=0; i<cot; i++)
{
int fu=father(l[i].u);
int fv=father(l[i].v);
if(fu==fv)continue;
fa[fv]=fu;
ans+=l[i].len;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: