您的位置:首页 > 其它

HDU1016:Prime Ring Problem(DFS)

2016-05-06 16:27 405 查看
Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
素数筛选法+深搜
上代码:
#include<iostream>
#include<cstring>

using namespace std;

int cnt;
int a[22];
int book[22];
int prime[50];
int n;
int Case;
void isPrime()
{
for(int i=1;i<50;i++)
prime[i]=1;

prime[0]=prime[1]=0;

for(int i=2;i<50;i++)
{
if(prime[i])
{
for(int j=2*i;j<50;j+=i)
prime[j]=0;
}

}

}

void dfs(int step)
{
if(step==n+1&&prime[a
+1])
{

cnt++;
//	cout<<"Case "<<Case<<":"<<endl;
for(int i=1;i<n;i++)
{
cout<<a[i]<<" ";
}
cout<<a
<<endl;

}

for(int i=2;i<=n;i++)
{
if(!book[i]&&prime[i+a[step-1]])
{
a[step]=i;
book[i]=1;
dfs(step+1);
book[i]=0;

}
}
return ;
}
int main()
{
isPrime();
while(cin>>n)
{
memset(book,0,sizeof(book));
Case++;
cout<<"Case "<<Case<<":"<<endl;
a[1]=1;
dfs(2);
cout<<endl;
}

return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: