您的位置:首页 > 其它

ZOJ 3326 An Awful Problem(模拟)

2016-05-04 15:50 417 查看
An Awful Problem

Time Limit: 1 Second Memory Limit: 32768 KB

In order to encourage Hiqivenfin to study math, his mother gave him a sweet candy when the day of the month was a prime number. Hiqivenfin was happy with that. But several days later,
his mother modified the rule so that he could get a candy only when the day of the month was a prime number and the month was also a prime number. He felt a bit upset because he could get fewer candies. What's worse, his mother changed the rule again and he
had to answer a question before he could get a candy in those days. The question was that how many candies he could get in the given time interval. Hiqivenfin wanted to cry and asked you for help. He promised to give you half of a candy if you could help him
to solve this problem.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 50), indicating the number of test cases. Then T test cases follow. The i-th
line of the next T lines contains two dates, the day interval of the question. The format of the date is "yyyy mm dd". You can assume both dates are valid. Hiqivenfin was born at 1000-01-01 and would not die after 2999-12-31, so the queries are all
in this interval.

Hiqivenfin didn't seem to be an earthman, but the calendar was the same as that we usually use. That is to say, you need to identify leap years, where February has 29 days. In the Gregorian
calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100,
and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Output

Output the number of candies Hiqivenfin could get in the time interval. Both sides of the interval are inclusive.

Sample Input

2
1000 01 01 1000 01 31
2000 02 01 2000 03 01


Sample Output

0
10

#include <iostream>
#include <string.h>

#include <math.h>
#include <stdio.h>

using namespace std;
int tag[50];
int tag2[50];
int res[50];
int t;
int year1,month1,day1,year2,month2,day2;
int judge(int year)
{
if(year%4==0&&year%100!=0||year%400==0)
return 1;
else
return 0;
}
int ans;
int main()
{
memset(tag,0,sizeof(tag));
tag[2]=1;tag[3]=1;tag[5]=1;tag[7]=1;tag[11]=1;
tag[13]=1;tag[17]=1;tag[19]=1;tag[23]=1;tag[29]=1;tag[31]=1;
tag2[1]=31;tag2[3]=31;tag2[5]=31;tag2[7]=31;tag2[8]=31;
tag2[10]=31;tag2[12]=31;
tag2[2]=28;tag2[4]=30;tag2[6]=30;tag2[9]=30;tag2[11]=30;
memset(res,0,sizeof(res));
res[2]=9;
res[3]=11;
res[5]=11;
res[7]=11;
res[11]=10;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d%d%d%d",&year1,&month1,&day1,&year2,&month2,&day2);
ans=0;
int flag=0;
if(year1==year2&&month1==month2)
flag=-2;
while((year1<year2)||(year1==year2&&month1<=month2))
{
if(year1==year2&&month1==month2&&flag!=-2)
flag=-1;
if(tag[month1])
{
if(flag<=0)
{
int sum,num;
if(flag==0)
{
sum=day1;
num=tag2[month1];
if(judge(year1)&&month1==2)
num=29;
}
else if(flag==-1)
{

sum=1;
num=day2;
}
else if(flag==-2)
{
sum=day1;
num=day2;
}
for(int i=sum;i<=num;i++)
{
if(tag[i])
ans++;
}

}

else
{
if(judge(year1))
res[2]=10;
else
res[2]=9;
ans+=res[month1];

}

}
month1++;
flag=1;
if(month1>12)
{
month1=1;
year1++;
}

}
printf("%d\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: