您的位置:首页 > 其它

1092. To Buy or Not to Buy (20)

2016-05-03 09:49 387 查看
Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether
a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary
beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between
the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258

YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225

YrR8RrY

Sample Output 1:

No 2

IDEA

1.使用map容器,map<char int>,颜色号作为key,个数作为value

2.若满足要求,则多购买的珠子数就等s1.length()-21.length();若不满足,每次计算每种珠子颜色缺几个,累加和为还需购买的珠子

CODE





#include<iostream>
#include<map>
#include<cstring>
#include<cstdio>
using namespace std;
int main(){
map<char,int> m1,m2;//char作为key,表示颜色;int作为value,表示个数
string s1,s2;
cin>>s1>>s2;
map<char,int>::iterator it,it1;
for(int i=0;i<s1.length();i++){
it=m1.find(s1[i]);
if(it!=m1.end()){
it->second++;
}else{
m1.insert(make_pair(s1[i],1));
}
}
/*	for(it=m1.begin();it!=m1.end();++it){
cout<<"key:"<<it->first<<" "<<"value:"<<it->second<<endl;
}*/
for(int i=0;i<s2.length();i++){
it=m2.find(s2[i]);
if(it!=m2.end()){
it->second++;
}else{
m2.insert(make_pair(s2[i],1));
}
}
/*	for(it=m2.begin();it!=m2.end();++it){
cout<<"key:"<<it->first<<" "<<"value:"<<it->second<<endl;
}*/
int count=0;
bool flag=true;
for(it1=m2.begin();it1!=m2.end();++it1){//m2 it1
it=m1.find(it1->first);//m1 it
if(it!=m1.end()){
if(it1->second<=it->second){

}else{
flag=false;
count+=(it1->second-it->second);
}
}else{
flag=false;
count+=it1->second;
}
}
if(flag){
cout<<"Yes "<<s1.length()-s2.length();
}else{
cout<<"No "<<count;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: