您的位置:首页 > 其它

POJ-3071 Football (概率DP)

2016-05-01 21:02 281 查看
Football
http://poj.org/problem?id=3071

Time Limit: 1000MSMemory Limit: 65536K
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the
double
data type instead
of
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题目大意:有2^n个队伍,总共进行n轮比赛,求获胜概率最大的队伍?

设dp[i][j]表示在第i轮,队伍j胜出的概率

则状态转移方程为:dp[i][j]=∑(p[j][k]*dp[i-1][j]*dp[i-1][k]),k为在第i轮可能会和j比赛的队伍

然后不知道怎么计算什么队伍之间会在第i轮比赛

看了题解后发现可以运用位运算,队号从0开始

观察规律(以0号队伍为例):

第一轮:(0,1)

第二轮:(0,2),(0,3)

第三轮:(0,4),(0,5),(0,6),(0,7)

……

第i轮能够比赛的队伍,他们从第i+1为开始均相同,而第i位均不同,所以可以对队号先右移i-1位,再让其中一个与1异或,若相等,则会在第i轮比赛

#include <cstdio>
#include <cstring>

using namespace std;
const int MAXN=131;

int n,nn,ans,team;
double dp[9][MAXN];//dp[i][j]表示在第i轮,队伍j胜出的概率
double p[MAXN][MAXN],mx;

int main() {
while(scanf("%d",&n),n!=-1) {
nn=1<<n;
for(int i=0;i<nn;++i) {
for(int j=0;j<nn;++j) {
scanf("%lf",&p[i][j]);
}
}
memset(dp,0,sizeof(dp));
for(int i=0;i<nn;++i) {
dp[0][i]=1;
}
for(int i=1;i<=n;++i) {
for(int j=0;j<nn;++j) {
team=(j>>(i-1))^1;
for(int k=0;k<nn;++k) {
if(team==(k>>(i-1))) {
dp[i][j]+=p[j][k]*dp[i-1][j]*dp[i-1][k];
}
}
}
}
mx=0;
for(int j=0;j<nn;++j) {
if(mx<dp
[j]) {
mx=dp
[j];
ans=j+1;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: