您的位置:首页 > 其它

练习三1005

2016-04-30 13:43 309 查看
Problem E
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 11
[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid
with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking
blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower
block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey
can build with a given set of blocks.<br>
 

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next
n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>
 

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>
 

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 

Statistic |

Submit |
Back
题意:
给出若干组不同型号的箱子的长宽高,每一种型号有无数个,求将箱子摞起来的最大高度,条件是在上面的箱子的长和宽必须都小于在下面的,箱子可以任意转动即每一条边都可以作为高。
思路:
还是一个类似求最长递增子数列的问题,把每一种型号的箱子分为三个即长作为高,宽作为高,高作为高,然后按照长从大到小排序,条件判断成立后按求最长递增子数列的方法计算即可。
代码:

#include<iostream>

#include<algorithm>

using namespace std;

struct cub

{

    int x,y,z;

};

int cmp(cub a,cub b)

{

    if(a.x==b.x)

    return a.y>b.y;

    return a.x>b.x;

}

int main()

{

    int n,q=0;

    while(cin>>n&&n)

    {

        q++;

        cub a[186];

        int b[186];

        for(int i=0;i<6*n;i+=6)

        {

            cin>>a[i].x>>a[i].y>>a[i].z;

            a[i+1].x=a[i].z;

            a[i+1].y=a[i].y;

            a[i+1].z=a[i].x;

            a[i+2].x=a[i].z;

            a[i+2].y=a[i].x;

            a[i+2].z=a[i].y;

            a[i+3].x=a[i].x;

            a[i+3].y=a[i].z;

            a[i+3].z=a[i].y;

            a[i+4].x=a[i].y;

            a[i+4].y=a[i].z;

            a[i+4].z=a[i].x;

            a[i+5].x=a[i].y;

            a[i+5].y=a[i].x;

            a[i+5].z=a[i].z;

        }

        sort(a,a+6*n,cmp);

        b[0]=a[0].z;

        for(int i=1;i<6*n;i++)

        {

            int tmp=0;

            for(int j=0;j<=i;j++)

            {

                if(a[i].x>=a[j].x||a[i].y>=a[j].y)

                continue;

                if(b[j]>tmp)

                tmp=b[j];

            }

            if(tmp==0) b[i]=a[i].z;

            else b[i]=tmp+a[i].z;

        }

        int sum=0;

        for(int i=0;i<6*n;i++)

        if(b[i]>sum)

        sum=b[i];

        cout<<"Case "<<q<<": maximum height = "<<sum<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: