您的位置:首页 > 其它

POJ2752 Seek the Name, Seek the Fame

2016-04-30 10:52 344 查看
题目链接:POJ2752

Seek the Name, Seek the Fame

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 15971Accepted: 8125
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu
[Submit] [Go Back] [Status]
[Discuss]

题意:求这个串哪些前缀的子串与后缀相同。
题目分析:主要在于对next数组的理解,next数组储存的是在当前位置的前缀与后缀相同的最长的长度,这样就好求了,我们从next[len]开始求,每次找到最长的公共前后缀,再递归的求子串的最长公共前后缀,直到-1为止,最后再倒序输出。

//
//  main.cpp
//  POJ2752
//
//  Created by teddywang on 16/4/30.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[400010];
int nexts[400010];
int num[400010];
int len;

void getnext()
{
int i=0,j=-1;
nexts[0]=-1;
while(i<len)
{
if(j==-1||s[i]==s[j])
{
nexts[++i]=++j;
}
else j=nexts[j];
}
}

int main()
{
while(~scanf("%s",s))
{
len=strlen(s);
getnext();
int sum=1;
num[0]=len;
int n=nexts[len];
while(n!=-1)
{
num[sum]=n;
n=nexts[num[sum++]];
}
for(int i=sum-2;i>0;i--)
printf("%d ",num[i]);
printf("%d\n",num[0]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: