您的位置:首页 > 其它

hdu 1003,nefu 728 max sum

2016-04-27 22:50 381 查看

Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7),
the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.


Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with
a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).


Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains
three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.


Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

//前1个数的DP值>=0,就加;DP值<0,就重新开始,自己本身。


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;
int data[100005],dp[100005];

int main()
{
int c,num=0,n;
cin>>c;
while(c--)
{
num++;
int maxx=-9999999,a=0,b=0;
memset(dp,0,sizeof(dp));
cin>>n;
for(int i=0;i<n;i++)
scanf("%d",&data[i]);
dp[0]=data[0];
for(int i=1;i<n;i++)
{
if(dp[i-1]>=0)
{
dp[i]=dp[i-1]+data[i];
}
else
{
dp[i]=data[i];
a=i;
}
if(dp[i]>maxx)
{
maxx=dp[i];
b=i;
}
}
printf("Case %d:\n",num);
printf("%d %d %d\n",maxx,a+1,b+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: