您的位置:首页 > 其它

HDU 1303 Doubles(水题)

2016-04-27 19:30 357 查看

Doubles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4461    Accepted Submission(s): 3072


[align=left]Problem Description[/align]
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some
other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

 

[align=left]Input[/align]
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99.
Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

 

[align=left]Output[/align]
The output will consist of one line per input list, containing a count of the items that are double some other item.

 

[align=left]Sample Input[/align]

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

 

[align=left]Sample Output[/align]

3
2
0

 

[align=left]Source[/align]
Mid-Central USA 2003

题解:计算有多少对是互为双倍的数。。。

AC代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;
int n[201];
int main()
{
int t;
char c;
while(cin>>t,t+1){
memset(n, 0, sizeof(n));
n[t]=1;
while(cin>>t,t)
n[t]=1;
int count = 0;

for(int i = 0; i < 200; i++)
if(n[i])
if(n[2 * i])
count++;
cout << count <<endl;

}
return 0;
}


AC2: 用vector。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
int temp;
while(cin>>temp&&temp!=-1)
{
vector<int> v;
v.push_back(temp);
while(cin>>temp&&temp!=0)
v.push_back(temp);
int sum=0;
for(int i=0;i!=v.size();++i)
{
auto b=find(v.cbegin(),v.cend(),2*v[i]);
if(b!=v.cend())
sum++;
}
cout<<sum<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: