您的位置:首页 > 其它

课程练习二-1016-Red and Black

2016-04-24 21:18 288 查看
Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.<br><br>Write
a program to count the number of black tiles which he can reach by repeating the moves described above. <br>

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.<br><br>There are H more lines in the
data set, each of which includes W characters. Each character represents the color of a tile as follows.<br><br>'.' - a black tile <br>'#' - a red tile <br>'@' - a man on a black tile(appears exactly once in a data set) <br>

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). <br>

 

Sample Input

6 9<br>....#.<br>.....#<br>......<br>......<br>......<br>......<br>......<br>#@...#<br>.#..#.<br>11 9<br>.#.........<br>.#.#######.<br>.#.#.....#.<br>.#.#.###.#.<br>.#.#..@#.#.<br>.#.#####.#.<br>.#.......#.<br>.#########.<br>...........<br>11 6<br>..#..#..#..<br>..#..#..#..<br>..#..#..###<br>..#..#..#@.<br>..#..#..#..<br>..#..#..#..<br>7 7<br>..#.#..<br>..#.#..<br>###.###<br>...@...<br>###.###<br>..#.#..<br>..#.#..<br>0 0<br>

 

Sample Output

45<br>59<br>6<br>13<br>
题意:有红、黑两种颜色,只能走黑色,上、下、左、右走。求走过的黑色的。
思路:dfs,注意走过的地方。
代码:#include <iostream> 
#include<stdlib.h> 
#include<string.h>
#include<fstream>
using namespace std;  
  
char a[25][25];  
int flag[25][25];  
int sum;  
  
void DFS(int x,int y)  
{  
    if(a[x-1][y]=='.' && flag[x-1][y]==0)  
    {  
        sum++;  
        flag[x-1][y]=1;  
        DFS(x-1,y);  
    }  
    if(a[x][y-1]=='.' && flag[x][y-1]==0)  
    {  
        sum++;  
        flag[x][y-1]=1;  
        DFS(x,y-1);  
    }  
    if(a[x][y+1]=='.' && flag[x][y+1]==0)  
    {  
        sum++;  
        flag[x][y+1]=1;  
        DFS(x,y+1);  
    }  
    if(a[x+1][y]=='.' && flag[x+1][y]==0)  
    {  
        sum++;  
        flag[x+1][y]=1;  
        DFS(x+1,y);  
    }  
}  
  
int main()  
{  
    freopen ("C:\\Users\\liuzhen\\Desktop\\11.txt", "r", stdin);
    int n,m,i,j;  
    while(cin>>m>>n)  
    {  
        if(m==0&&n==0)
break; 
        sum=0;  
        memset(flag,0,sizeof(flag));  
        memset(a,'#',sizeof(a));  
        for(i=1;i<=n;i++)  
        {  
            for(j=1;j<=m;j++)  
            {  
                cin>>a[i][j];  
            }  
        }  
        for(i=1;i<=n;i++)  
        {  
            for(j=1;j<=m;j++)  
            {  
                if(a[i][j]=='@')  
                {  
                    sum++;  
                    flag[i][j]=1;  
                    DFS(i,j);  
                    i=n;  
                    j=m;  
                }  
            }  
        }  
        cout<<sum<<endl;  
    }  
    freopen ("con", "r", stdin);
    system("pause");
    return 0;  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm