您的位置:首页 > 运维架构

zoj-3944-People Counting

2016-04-24 21:08 344 查看
In a BG (dinner gathering) for ZJU ICPC team, the coaches wanted to count the number of people present at the BG. They did that by having the waitress take a photo for them. Everyone was in the photo and no one was completely blocked. Each person in the photo has the same posture. After some preprocessing, the photo was converted into a H×W character matrix, with the background represented by “.”. Thus a person in this photo is represented by the diagram in the following three lines:

.O.

/|\

(.)

Given the character matrix, the coaches want you to count the number of people in the photo. Note that if someone is partly blocked in the photo, only part of the above diagram will be presented in the character matrix.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers H, W (1 ≤ H, W ≤ 100) - as described above, followed by H lines, showing the matrix representation of the photo.

Output

For each test case, there should be a single line, containing an integer indicating the number of people from the photo.

Sample Input

2

3 3

.O.

/|\

(.)

3 4

OOO(

/|\

()))

Sample Output

1

4

数人的个数

看题目的意思搜一遍枚举就好了

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn = 105;
char m[maxn][maxn];
bool vis[maxn][maxn];
int h, w;

void check(int r, int c){
vis[r][c] = true;
if (m[r][c] == 'O'){
if (r+1<h && m[r+1][c]=='|')
vis[r+1][c] = true;
if (r+1<h && c+1<w && m[r+1][c+1]=='\\')
vis[r+1][c+1] = true;
if (r+1<h && c-1>=0 && m[r+1][c-1]=='/')
vis[r+1][c-1] = true;
if (r+2<h && c-1>=0 && m[r+2][c-1]=='(')
vis[r+2][c-1] = true;
if (r+2<h && c+1<w && m[r+2][c+1]==')')
vis[r+2][c+1] = true;
}
else if (m[r][c] == '|'){
if (c+1<w && m[r][c+1]=='\\')
vis[r][c+1] = true;
if (r+1<h && c-1>=0 && m[r+1][c-1]=='(')
vis[r+1][c-1] = true;
if (r+1<h && c+1<w && m[r+1][c+1]==')')
vis[r+1][c+1] = true;
}
else if (m[r][c] == '/'){
if (c+1<w && m[r][c+1]=='|')
vis[r][c+1] = true;
if (c+2<w && m[r][c+2]=='\\')
vis[r][c+2] = true;
if (r+1<h && c+2<w && m[r+1][c+2]==')')
vis[r+1][c+2] = true;
if (r+1<h && m[r+1][c]=='(')
vis[r+1][c] = true;
}
else if (m[r][c] == '\\'){
if (r+1<h && m[r+1][c]==')')
vis[r+1][c] = true;
if (r+1<h && c-2>=0 && m[r+1][c-2]=='(')
vis[r+1][c-2] = true;
}
else if (m[r][c] == '('){
if (c+2<w && m[r][c+2]==')')
vis[r][c+2] = true;
}
}

int main(){
int t;
scanf("%d", &t);
while (t--){
scanf("%d%d", &h, &w);
for (int i=0; i<h; ++i)
scanf("%s", m+i);
int cnt = 0;
memset(vis, false, sizeof(vis));
for (int i=0; i<h; ++i)
for (int j=0; j<w; ++j)
if (!vis[i][j] && (m[i][j]=='O'||m[i][j]=='|'||m[i][j]=='/'||m[i][j]=='\\'||m[i][j]=='('||m[i][j]==')'))
{
++cnt;
check(i, j);
}
printf("%d\n", cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: