您的位置:首页 > 其它

Red and Black

2016-04-24 20:35 225 查看
Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.<br><br>Write
a program to count the number of black tiles which he can reach by repeating the moves described above. <br>

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.<br><br>There are H more lines in the
data set, each of which includes W characters. Each character represents the color of a tile as follows.<br><br>'.' - a black tile <br>'#' - a red tile <br>'@' - a man on a black tile(appears exactly once in a data set) <br>

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). <br>

 

Sample Input

6 9<br>....#.<br>.....#<br>......<br>......<br>......<br>......<br>......<br>#@...#<br>.#..#.<br>11 9<br>.#.........<br>.#.#######.<br>.#.#.....#.<br>.#.#.###.#.<br>.#.#..@#.#.<br>.#.#####.#.<br>.#.......#.<br>.#########.<br>...........<br>11 6<br>..#..#..#..<br>..#..#..#..<br>..#..#..###<br>..#..#..#@.<br>..#..#..#..<br>..#..#..#..<br>7 7<br>..#.#..<br>..#.#..<br>###.###<br>...@...<br>###.###<br>..#.#..<br>..#.#..<br>0 0<br>

 

Sample Output

45<br>59<br>6<br>13<br>

 

一道搜索题:

求最多的黑快,一开始以为是搜路径直接dfs,可是这个是求最大的路径还要用是bfs

bfs条件是。切不是图外且是上一个的上下左右。

代码:

#include<queue>

#include<iostream>

#include<string.h>

#include<cstdio>

using namespace std;

int n,m;

char map[30][30];

struct ans

{

    int x;

    int y;

}n1,n2;

int ww(int a,int b)

{

    if(a>0&&a<=m&&b>0&&b<=n)

     return 1;

    return 0;

}

int BFS(int k,int z)

{

    int num=0,i;

    n1.x=k;

    n1.y=z;

    int disx[6]={-1,1,0,0};

    int disy[6]={0,0,-1,1};

    queue<ans> Q;

    Q.push(n1);

9081
    while(!Q.empty())

    {

        n1=Q.front();

        Q.pop();

        for(i=0;i<4;i++)

        {

            n2.x=n1.x+disx[i];

            n2.y=n1.y+disy[i];

            if(ww(n2.x,n2.y)&&map[n2.x][n2.y]=='.')

            {

                num++;

                Q.push(n2);

                map[n2.x][n2.y]='#';

            }

        }

    }

    return num+1;

}

int main()

{

    int j,i,t,k,z;

    char x;

    while(cin>>n>>m&&n!=0||m!=0)

    {

        for(i=1;i<=m;i++)

        {

            for(j=1;j<=n;j++)

            {

                cin>>map[i][j];

                if(map[i][j]=='@') {k=i;z=j;}

            }

        }

        t=BFS(k,z);

        cout<<t<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: