您的位置:首页 > 产品设计 > UI/UE

Rescue宽度搜索的最优解

2016-04-24 15:16 483 查看
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.<br><br>Angel's friends want to save Angel. Their task is: approach Angel. We assume
that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes
1 unit time, too. And we are strong enough to kill all the guards.<br><br>You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)<br>

 

Input

First line contains two integers stand for N and M.<br><br>Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. <br><br>Process to the end of the file.<br>

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." <br>

 

Sample Input

7 8<br>#.#####.<br>#.a#..r.<br>#..#x...<br>..#..#.#<br>#...##..<br>.#......<br>........<br>

 

Sample Output

13<br>

题意:X代表卫兵,a代表终点,r代表起始点,.代表路,#代表墙

路花费一秒,x花费两秒

问到达终点的最少时间

#include<iostream>

#include <stdio.h>

#include <string.h>

#include <queue>

using namespace std;

struct node

{

    int x,y,step;

    friend bool operator<(node n1,node n2)//重载小于号,时间作为比较对象

    {

        return n2.step<n1.step;

    }

};

int n,m,vis[205][205];  //标记

char map[205][205];//地图

int x1,x2,y1,y2;

int to[4][2] = {1,0,-1,0,0,1,0,-1}; //方向数组

int check(int x,int y)

{

    if(x<0 || y<0 || x>=n || y>=m || !vis[x][y] || map[x][y] == '#')

        return 1;

    return 0;

}

int bfs()

{

    int i;

    priority_queue<node> Q;  //优先队列

    node a,next;

    a.x = x1;

    a.y = y1;

    a.step = 0;

    Q.push(a);

    vis[x1][y1] = 0;

    while(!Q.empty())

    {

        a = Q.top();

        Q.pop();

        if(a.x == x2 && a.y == y2)

            return a.step;

        for(i = 0; i<4; i++)

        {

            next = a;

            next.x+=to[i][0];  //方向寻找

            next.y+=to[i][1];

            if(check(next.x,next.y))//判断是否符合要求

                continue;

            next.step++;

            if(map[next.x][next.y] == 'x')//卫兵处多花费了一秒

                next.step++;

            if(vis[next.x][next.y]>=next.step)//存入最小时间

            {

                vis[next.x][next.y] = next.step;

                Q.push(next);  //符合要求就检查下一个

            }

        }

    }

    return 0;

}

int main()

{

    int i,j;

    while(~scanf("%d%d",&n,&m))

    {

        for(i = 0; i<n; i++)

        {

            scanf("%s",map[i]);

            for(j = 0; map[i][j]; j++)

            {

                if(map[i][j] == 'r')

                {

                    x1 = i;

                    y1 = j;

                }

                else if(map[i][j] == 'a')

                {

                    x2 = i;

                    y2 = j;

                }

            }

        }

        memset(vis,1,sizeof(vis));

        int ans = 0;

        ans = bfs();

        if(ans)

            printf("%d\n",ans);

        else

            printf("Poor ANGEL has to stay in the prison all his life.\n");

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: