您的位置:首页 > 其它

ACM2-1014

2016-04-24 09:52 162 查看
Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki
floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there
is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't
go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?<br>

 

Input

The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.

 

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

 

Sample Input

5 1 5<br>3 3 1 2 5<br>0

 

Sample Output

3

 
使用bfs算法
#include<cstdio>

#include<cstring>

#define maxn 250

#define INF 0x3f3f3f3f

int dp[maxn],floor[maxn][2];//floor[i][0]

{

    int n,a,b;

    while(scanf("%d",&n),n)

    {

        scanf("%d %d",&a,&b);

        memset(floor,-1,sizeof(floor));

        for(int i=1;i<=n;i++)

        {

            int t;

            scanf("%d",&t);

            if(i+t<=n)

                floor[i][0]=i+t;

            if(i-t>=1)

                floor[i][1]=i-t;

        }

        memset(dp,0x3f,sizeof(dp));

        dp[a]=0;

        while(true)

        {

            int num=0;

            for(int i=1;i<=n;i++) if(dp[i]<INF)

                for(int j=0;j<2;j++) if(floor[i][j]!=-1)

                    if(dp[floor[i][j]]>dp[i]+1)

                        dp[floor[i][j]]=dp[i]+1,num++;

                    if(num==0)

                        break;

        }

        if(dp[b]==INF)

            dp[b]=-1;

        printf("%d\n",dp[b]);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm