您的位置:首页 > 产品设计 > UI/UE

HDU-2767 Proving Equivalences (强连通分量[Tarjan])

2016-04-23 11:02 411 查看


Proving Equivalences

http://acm.hdu.edu.cn/showproblem.php?pid=2767

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)



Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.

2. Ax = b has exactly one solution for every n × 1 matrix b.

3. Ax = b is consistent for every n × 1 matrix b.

4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the
four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a
lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3


Sample Output

4
2


题目大意:给定一个无向图,求至少要加多少条边,才能使得从任何一个顶点出发,都能到达全部顶点?

解法同POJ-2186,为了熟悉Tarjan算法,又手敲一遍,但是连续两次都犯同样的错误,把j写成i,这样都能过好多数据...debug好累

#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

const int MAXN=20005;

int n,m,s,e,num,cnt;//num表示时间戳,cnt表示强连通分量个数
int stak[MAXN],top;//top指向栈顶元素的后一个,也表示栈内元素个数
int dfn[MAXN],low[MAXN],color[MAXN],indeg[MAXN],outdeg[MAXN];
vector<int> edge[MAXN];
bool isIn[MAXN];//isIn[i]表示点i是否在栈中

void Tarjan(int u) {
dfn[u]=low[u]=++num;
stak[top++]=u;
isIn[u]=true;
int v;
for(int i=0;i<edge[u].size();++i) {
v=edge[u][i];
if(dfn[v]==0) {
Tarjan(v);
low[u]=min(low[u],low[v]);
}
else if(isIn[v]&&dfn[v]<low[u])
low[u]=dfn[v];
}

if(dfn[u]==low[u]) {
++cnt;
do {
v=stak[--top];
isIn[v]=false;//v已出栈
color[v]=cnt;//强连通分量缩成一点
} while(u!=v);
}
}

void solve() {
num=cnt=top=0;
memset(dfn,0,sizeof(dfn));
memset(isIn,false,sizeof(isIn));
for(int i=1;i<=n;++i) {//防止原图不连通
if(dfn[i]==0)
Tarjan(i);
}

memset(indeg,0,sizeof(indeg));
memset(outdeg,0,sizeof(outdeg));
for(int i=1;i<=n;++i) {
for(int j=0;j<edge[i].size();++j)
if(color[i]!=color[edge[i][j]]) {//统计每个缩点的出入度
++outdeg[color[edge[i][j]]];
++indeg[color[i]];
}
}

int cntIn=0,cntOut=0;//cntIn和cntOut分别为入度和出度为0的缩点个数
for(int i=1;i<=cnt;++i) {
if(indeg[i]==0)
++cntIn;
if(outdeg[i]==0)
++cntOut;
}
printf("%d\n",cnt==1?0:max(cntIn,cntOut));
}

int main() {
int T;
scanf("%d",&T);
while(T-->0) {
scanf("%d%d",&n,&m);
for(int i=1;i<=n;++i)
edge[i].clear();
while(m-->0) {
scanf("%d%d",&s,&e);
edge[s].push_back(e);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: