您的位置:首页 > 其它

UVA - 494 Kindergarten Counting Game

2016-04-22 23:12 225 查看
Kindergarten Counting Game

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...


Sample Output

2
7
10
9

分析:
统计单词个数的题目

水
代码:
#include <stdio.h>
#include <ctype.h>
#include <string.h>
#define N 10000
char a
;
int main()
{
//freopen("abc.txt","r",stdin);
int n;

while(gets(a)!=NULL)
{
n=strlen(a);
int found,count=0;
for(int i=0;i<n;i++)
{
if(isalpha(a[i])) found=1;
else{
if(found) count++;
found =0;
}

}
printf("%d\n",count);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: