您的位置:首页 > 其它

AYIT606第六周周六赛 (多重背包) E - Cash Machine 自动取款机

2016-04-20 17:38 316 查看
E - Cash Machine
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1276

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply
of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10


Sample Output

735
630
0
0


Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered
cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

分析:

利用了多重背包的算法,遍历出小于等于n的所有数是否可以由后边的货币面值兑换,然后找出能被兑换的货币的最大值!

当遍历的时候,一个货币只有两种可能,要么被兑换,要么不兑换!

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[100010];
int main()
{
int m,n,a,b,t,s,i,j;
while(scanf("%d%d",&m,&n)!=EOF)
{
memset(dp,0,sizeof(dp));
dp[0]=1;
while(n--)
{
scanf("%d%d",&a,&b);
for(i=1; a>0; i++)
{
t=min(a,i);
a-=i;
s=t*b;
for(j=m; j>=s; j--)
dp[j]=max(dp[j],dp[j-s]);
}
}
for(i=m; i>=0; i--)
if(dp[i])
{
printf("%d\n",i);
break;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: