您的位置:首页 > 其它

HDU - 5665 Lucky (技巧)

2016-04-20 14:02 218 查看
HDU
- 5665
Lucky

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u
Submit Status

Description








Chaos
August likes to study the lucky numbers. 








For
a set of numbers S,we set the minimum non-negative integer,which can't be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times. 








Now,
given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".
 

Input








The
first line is a number T,which is case number. 








In
each case,the first line is a number n,which is the size of the number set. 








Next
are n numbers,means the number in the number set. 






















































.
 

Output








Output“YES”or
“NO”to every query.
 

Sample Input

1
1
2

 

Sample Output

NO

 

Source
BestCoder Round #80
//题意:
给你n个数,问你用这些数相加,是否可以得到最小的非负整数(0和1)?
//思路:
只用判断给的数中是否有0和1就行了,只有一个也是不行的
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
bool f1=false,f2=false;
for(int i=0;i<n;i++)
{
int a;
scanf("%d",&a);
if(a==1)
f1=true;
if(a==0)
f2=true;
}
if(f1&&f2) printf("YES\n");
else printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: