您的位置:首页 > 其它

ACM刷题之HDU————Rank

2016-04-19 21:57 253 查看

Rank

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4407 Accepted Submission(s): 1258
Problem Description

Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied)
his rank is 2, and so on.

Input

The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark
between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

Output

For each test case, output a line giving Jackson’s rank in the class.

Sample Input

20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0


Sample Output

2


也是当初step留下来的题目。当时感觉很麻烦,而且也不一定能做出来。最近刚自学了结构体,正好练练手
注意:
1.题目里面要求是如果和jackson同分,就要jackson先。
2.题目里是按分数从大到小排!ORZ,,我竟然排反了。

中间还用到了结构体的排序。要自己定义cmp函数(感谢SpLinter_Cell 给的排序方法


下面是ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
typedef struct ranks{
int ids;
int score;
}rank;
bool cmp(const ranks &a,const ranks &b){
return a.score>b.score;
}
int main()
{
ranks r[10011];
int jackson,i,j,x;
while(scanf("%d",&jackson)!=EOF)
{
i=0;
while(scanf("%d%d",&r[i].ids,&r[i].sco re)!=EOF)
{
if(r[i].ids==0&&r[i].score==0)
break;
if(r[i].ids==jackson)
x=r[i].score;
i++;
}
sort(r,r+i,cmp);
for(j=0;j<i;j++)
{

if(r[j].score==x)
{
printf("%d\n",j+1);
break;
}
}
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: