您的位置:首页 > 其它

acm 2 1003 pie

2016-04-17 20:08 190 查看
1.1003

2.

[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This
should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them
should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
<br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri
with 1 <= ri <= 10 000: the radii of the pies.<br>

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

[align=left]Sample Input[/align]

3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>

[align=left]Sample Output[/align]

25.1327<br>3.1416<br>50.2655<br>

[align=left]Source[/align]
NWERC2006

3.基本题意,n个蛋糕半径,m+1个人,每个人分得的蛋糕的必须是整块的不能进行拼接,求最大

4.分蛋糕问题*-*,明显二分,因为题中要求不能进行拼接,所以直接在0和max之间进行二分法求解

5.#include<iostream>

#include<vector>

#include<algorithm>

#include<numeric>

#include<iomanip>

using namespace std;

double PI=acos(-1.0);

int main()

{

    double n,f,r,l,mid,maxx,sum,radio;

    double pie[100010];

    int N,i,num,t;

    cin>>N;

    while(N--)

    {   cin>>n>>f;

        f++;

        sum=maxx=0;

        for(i=0;i<n;i++)

        {

            cin>>radio;

            pie[i]=radio*PI*radio;

            maxx=max(maxx,pie[i]);

            sum+=pie[i];

        }

        r=sum/f;

        l=0;

        while(r-l>0.00001)

        {

            num=0;mid=(r+l)/2;

            for(i=0;i<n;i++)

            {

                num+=(int)(pie[i]/mid);

            }

            if(num<f) r=mid;

            else l=mid;

        }

        printf("%.4f\n",l);

    }

     return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: