您的位置:首页 > 其它

POJ 2139 Six Degrees of Cowvin Bacon

2016-04-16 21:37 435 查看
Six Degrees of Cowvin Bacon

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4239Accepted: 2008
Description
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.

Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.

Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input
4 2
3 1 2 3
2 3 4

Sample Output
100

Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

和这一题很像:http://blog.csdn.net/sdfgdbvc/article/details/51164791

都是路线内站点两两互相关系为1,每换一个路线两点关系+1,求最短路径

#include <stdio.h>
#include <string.h>
int N, M;
int map[305][305];
int group[305];
int main()
{
int i, j, k, x, max;
while(scanf("%d%d", &N, &M) != EOF)
{
memset(map, 0x3f, sizeof(map));
for(i = 1; i <= N; i++)
map[i][i] = map[i][0] = 0;
for(i = 1; i <= M; i++)
{
scanf("%d", &x);
for(j = 1; j <= x; j++)
scanf("%d", &group[j]);
for(j = 1; j <= x; j++)
for(k = j + 1; k <= x; k++)
map[group[j]][group[k]] = map[group[k]][group[j]] = 1;
}
for(k = 1; k <= N; k++)
for(i = 1; i <= N; i++)
for(j = 1; j <= N; j++)
if(map[i][j] > map[i][k] + map[k][j])
map[i][j] = map[i][k] + map[k][j];
for(i = 1; i <= N; i++)
for(j = 1; j <= N; j++)
map[i][0] += map[i][j];
max = 0x3f3f3f3f;
for(i = 1; i <= N; i++)
if(map[i][0] < max)
max = map[i][0];
printf("%d\n", (int)(100*((double)max / (N - 1))));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: